Ejemplo n.º 1
0
    def given_an_open_connection(self):
        connection_info = {'username': '******', 'password': '******', 'virtual_host': '/'}
        task = asyncio.ensure_future(open_connection(self.loop, self.transport, self.protocol, self.dispatcher, connection_info))
        self.tick()

        start_method = spec.ConnectionStart(0, 9, {}, 'PLAIN AMQPLAIN', 'en_US')
        self.server.send_method(0, start_method)

        tune_method = spec.ConnectionTune(0, 131072, 600)
        self.frame_max = tune_method.frame_max
        self.server.send_method(0, tune_method)

        self.server.send_method(0, spec.ConnectionOpenOK(''))

        self.connection = task.result()
Ejemplo n.º 2
0
    def given_an_open_connection(self):
        connection_info = ConnectionInfo('guest', 'guest', '/')
        task = asyncio. async (open_connection(self.loop, self.protocol,
                                               self.dispatcher,
                                               connection_info))
        self.tick()

        start_method = spec.ConnectionStart(0, 9, {}, 'PLAIN AMQPLAIN',
                                            'en_US')
        self.server.send_method(0, start_method)

        tune_method = spec.ConnectionTune(0, 131072, 600)
        self.frame_max = tune_method.frame_max
        self.server.send_method(0, tune_method)

        self.server.send_method(0, spec.ConnectionOpenOK(''))

        self.connection = task.result()
Ejemplo n.º 3
0
    def given_an_open_connection(self):
        task = asyncio. async (open_connection(self.loop, self.protocol,
                                               self.dispatcher,
                                               self.connection_info))
        self.tick()

        start_frame = asynqp.frames.MethodFrame(
            0, spec.ConnectionStart(0, 9, {}, 'PLAIN AMQPLAIN', 'en_US'))
        self.dispatcher.dispatch(start_frame)
        self.tick()

        self.frame_max = 131072
        tune_frame = asynqp.frames.MethodFrame(
            0, spec.ConnectionTune(0, self.frame_max, 600))
        self.dispatcher.dispatch(tune_frame)
        self.tick()

        open_ok_frame = asynqp.frames.MethodFrame(0, spec.ConnectionOpenOK(''))
        self.dispatcher.dispatch(open_ok_frame)
        self.tick()

        self.protocol.reset_mock()
        self.connection = task.result()
Ejemplo n.º 4
0
 def establish_the_frame(self):
     self.raw = b'\x01\x00\x00\x00\x00\x00\x05\x00\x0A\x00\x29\x00\xCE\x01\x00\x00\x00\x00\x00\x05\x00\x0A'
     method = spec.ConnectionOpenOK('')
     self.expected_frame = asynqp.frames.MethodFrame(0, method)
Ejemplo n.º 5
0
 def establish_the_frame(self):
     method = spec.ConnectionOpenOK('')
     self.expected_frame = asynqp.frames.MethodFrame(0, method)
Ejemplo n.º 6
0
 def establish_the_frame(self):
     self.raw = b'\x01\x00\x00\x00\x00\x00\x05\x00\x0A\x00\x29\x00\xCE'
     method = spec.ConnectionOpenOK('')
     self.expected_frame = asynqp.frames.MethodFrame(0, method)
     self.protocol.heartbeat_monitor = mock.Mock(
         spec=protocol.HeartbeatMonitor)