Ejemplo n.º 1
0
	def _start_ebuild(self):
		if self.phase == "package":
			self._start_task(PackagePhase(actionmap=self.actionmap,
				background=self.background, fd_pipes=self.fd_pipes,
				logfile=self._get_log_path(), scheduler=self.scheduler,
				settings=self.settings), self._ebuild_exit)
			return

		if self.phase == "unpack":
			alist = self.settings.configdict["pkg"].get("A", "").split()
			_prepare_fake_distdir(self.settings, alist)
			_prepare_fake_filesdir(self.settings)

		fd_pipes = self.fd_pipes
		if fd_pipes is None:
			if not self.background and self.phase == 'nofetch':
				# All the pkg_nofetch output goes to stderr since
				# it's considered to be an error message.
				fd_pipes = {1 : sys.__stderr__.fileno()}

		ebuild_process = EbuildProcess(actionmap=self.actionmap,
			background=self.background, fd_pipes=fd_pipes,
			logfile=self._get_log_path(), phase=self.phase,
			scheduler=self.scheduler, settings=self.settings)

		self._start_task(ebuild_process, self._ebuild_exit)
Ejemplo n.º 2
0
    def _start_ebuild(self):
        if self.phase == "package":
            self._start_task(
                PackagePhase(actionmap=self.actionmap,
                             background=self.background,
                             fd_pipes=self.fd_pipes,
                             logfile=self._get_log_path(),
                             scheduler=self.scheduler,
                             settings=self.settings), self._ebuild_exit)
            return

        if self.phase == "unpack":
            alist = self.settings.configdict["pkg"].get("A", "").split()
            _prepare_fake_distdir(self.settings, alist)
            _prepare_fake_filesdir(self.settings)

        fd_pipes = self.fd_pipes
        if fd_pipes is None:
            if not self.background and self.phase == 'nofetch':
                # All the pkg_nofetch output goes to stderr since
                # it's considered to be an error message.
                fd_pipes = {1: sys.__stderr__.fileno()}

        ebuild_process = EbuildProcess(actionmap=self.actionmap,
                                       background=self.background,
                                       fd_pipes=fd_pipes,
                                       logfile=self._get_log_path(),
                                       phase=self.phase,
                                       scheduler=self.scheduler,
                                       settings=self.settings)

        self._start_task(ebuild_process, self._ebuild_exit)
Ejemplo n.º 3
0
	def _start_ebuild(self):

		if self.phase == "unpack":
			_prepare_fake_filesdir(self.settings)

		fd_pipes = self.fd_pipes
		if fd_pipes is None:
			if not self.background and self.phase == 'nofetch':
				# All the pkg_nofetch output goes to stderr since
				# it's considered to be an error message.
				fd_pipes = {1 : sys.__stderr__.fileno()}

		ebuild_process = EbuildProcess(actionmap=self.actionmap,
			background=self.background, fd_pipes=fd_pipes,
			logfile=self._get_log_path(), phase=self.phase,
			scheduler=self.scheduler, settings=self.settings)

		self._start_task(ebuild_process, self._ebuild_exit)
Ejemplo n.º 4
0
    def _start_ebuild(self):

        if self.phase == "unpack":
            _prepare_fake_filesdir(self.settings)

        fd_pipes = self.fd_pipes
        if fd_pipes is None:
            if not self.background and self.phase == 'nofetch':
                # All the pkg_nofetch output goes to stderr since
                # it's considered to be an error message.
                fd_pipes = {1: sys.__stderr__.fileno()}

        ebuild_process = EbuildProcess(actionmap=self.actionmap,
                                       background=self.background,
                                       fd_pipes=fd_pipes,
                                       logfile=self._get_log_path(),
                                       phase=self.phase,
                                       scheduler=self.scheduler,
                                       settings=self.settings)

        self._start_task(ebuild_process, self._ebuild_exit)