Example #1
0
 def when_QueueBindOK_arrives(self):
     self.server.send_method(self.channel.id, spec.QueueBindOK())
     self.binding = self.task.result()
Example #2
0
 def given_a_bound_queue(self):
     task = asyncio.ensure_future(self.queue.bind(self.exchange, 'routing.key'))
     self.tick()
     self.server.send_method(self.channel.id, spec.QueueBindOK())
     self.binding = task.result()