Example #1
0
 def it_should_send_a_QueueDeclare_method(self):
     expected_method = spec.QueueDeclare(0, 'my.nice.queue', False, True,
                                         True, True, False, {
                                             'x-expires': 300,
                                             'x-message-ttl': 1000
                                         })
     self.server.should_have_received_method(self.channel.id,
                                             expected_method)
Example #2
0
 def it_should_have_sent_nowait_in_frame(self):
     self.server.should_have_received_method(
         self.channel.id, spec.QueueDeclare(
             0, '123', False, True, True, False, True, {}))
Example #3
0
 def given_a_method_to_send(self):
     self.method = spec.QueueDeclare(0, 'a', False, False, False, True, False, {})
Example #4
0
 def it_should_send_a_QueueDeclare_method(self):
     expected_method = spec.QueueDeclare(0, 'my.nice.queue', False, True,
                                         True, True, False, {})
     self.server.should_have_received_method(self.channel.id,
                                             expected_method)