Example #1
0
         'concurrent_tile_creators': int(),
         'disable_storage': bool(),
         'format': str(),
         'image': image_opts,
         'request_format': str(),
         'use_direct_from_level': number(),
         'use_direct_from_res': number(),
         'link_single_color_images': bool(),
         'watermark': {
             'text': string_type,
             'font_size': number(),
             'color': one_of(str(), [number()]),
             'opacity': number(),
             'spacing': str(),
         },
         'cache': type_spec('type', cache_types)
     }
 },
 'services': {
     'demo': {},
     'kml': {
         'use_grid_names': bool(),
     },
     'tms': {
         'use_grid_names': bool(),
         'origin': str(),
     },
     'wmts': {
         'kvp': bool(),
         'restful': bool(),
         'restful_template': str(),
Example #2
0
         'concurrent_tile_creators': int(),
         'disable_storage': bool(),
         'format': str(),
         'image': image_opts,
         'request_format': str(),
         'use_direct_from_level': number(),
         'use_direct_from_res': number(),
         'link_single_color_images': bool(),
         'watermark': {
             'text': string_type,
             'font_size': number(),
             'color': one_of(str(), [number()]),
             'opacity': number(),
             'spacing': str(),
         },
         'cache': type_spec('type', cache_types)
     }
 },
 'services': {
     'demo': {},
     'kml': {
         'use_grid_names': bool(),
     },
     'tms': {
         'use_grid_names': bool(),
         'origin': str(),
     },
     'wmts': {
         'kvp': bool(),
         'restful': bool(),
         'restful_template': str(),