Example #1
0
 def _request_bashrcs(self, ebd):
     for source in self.domain.get_package_bashrcs(self.pkg):
         if source.path is not None:
             ebd.write(f"path\n{source.path}")
         elif source.get_data is not None:
             raise NotImplementedError
         else:
             chuck_UnhandledCommand(
                 ebd, "bashrc request: unable to process bashrc "
                 f"due to source '{source}' due to lacking usable get_*")
         if not ebd.expect("next"):
             chuck_UnhandledCommand(
                 ebd, "bashrc transfer, didn't receive 'next' response.  "
                 "failure?")
     ebd.write("end_request")
Example #2
0
 def _request_bashrcs(self, ebd):
     for source in self.domain.get_package_bashrcs(self.pkg):
         if source.path is not None:
             ebd.write(f"path\n{source.path}")
         elif source.get_data is not None:
             raise NotImplementedError
         else:
             chuck_UnhandledCommand(
                 ebd, "bashrc request: unable to process bashrc "
                 f"due to source '{source}' due to lacking usable get_*")
         if not ebd.expect("next"):
             chuck_UnhandledCommand(
                 ebd, "bashrc transfer, didn't receive 'next' response.  "
                 "failure?")
     ebd.write("end_request")