예제 #1
0
 def it_should_send_start_ok(self):
     expected_method = spec.ConnectionStartOK(
         {"product": "asynqp", "version": "0.1", "platform": sys.version},
         'AMQPLAIN',
         {'LOGIN': '******', 'PASSWORD': '******'},
         'en_US'
     )
     self.server.should_have_received_method(0, expected_method)
예제 #2
0
 def it_should_send_start_ok(self):
     expected_method = spec.ConnectionStartOK(
         {"product": "asynqp", "version": "0.1", "platform": sys.version,
          "capabilities": {
              "consumer_cancel_notify": True
          }},
         'AMQPLAIN',
         {'LOGIN': '******', 'PASSWORD': '******'},
         'en_US'
     )
     self.server.should_have_received_method(0, expected_method)
예제 #3
0
 def given_a_method_to_send(self):
     method = spec.ConnectionStartOK({'somecrap': 'aboutme'}, 'AMQPLAIN', {'auth': 'info'}, 'en_US')
     self.frame = asynqp.frames.MethodFrame(0, method)