Exemplo n.º 1
0
 def given_a_method_to_send(self):
     method = spec.ConnectionTuneOK(1024, 131072, 10)
     self.frame = asynqp.frames.MethodFrame(0, method)
Exemplo n.º 2
0
 def it_should_send_tune_ok_followed_by_open(self):
     tune_ok_method = spec.ConnectionTuneOK(0, 131072, 600)
     open_method = spec.ConnectionOpen('/', '', False)
     self.server.should_have_received_methods(0,
                                              [tune_ok_method, open_method])