Пример #1
0
 def test_registry_uris_param_v2(self):
     spec = CommonSpec()
     spec.set_params(registry_uris=['http://registry.example.com:5000/v2'],
                     user=TEST_USER)
     registry = spec.registry_uris.value[0]
     assert registry.uri == 'http://registry.example.com:5000'
     assert registry.docker_uri == 'registry.example.com:5000'
     assert registry.version == 'v2'
Пример #2
0
 def __init__(self, build_json_store):
     """
     :param build_json_store: str, path to directory with JSON build files
     """
     super(CommonBuild, self).__init__(build_json_store)
     self.spec = CommonSpec()