Пример #1
0
def get_brain_spec(conf):
    """
    Returns the brain specification corresponding to the
    given config.
    :param conf:
    :return:
    """
    return default_neural_net(conf.brain_mutation_epsilon)
Пример #2
0
def get_brain_spec(conf):
    """
    Returns the brain specification corresponding to the
    given config.
    :param conf:
    :return:
    """
    return default_neural_net(conf.brain_mutation_epsilon)
Пример #3
0
            arity=1,
            outputs=1,

            # Add color parameters to this part
            params=color_params
        ),
        "Hinge": PartSpec(
            body_part=PassiveHinge,
            arity=2,
            params=color_params + [ParamSpec("length", min_value=0.1, max_value=1, default=0.5)]
        )
    }
)

# For the brain, we use the default neural network
brain_spec = default_neural_net()

# Specify a body generator for the specification
body_gen = BodyGenerator(
    body_spec,

    # List all parts that can serve as the robot root
    root_parts=["Core"],

    # List all parts that can be attached
    attach_parts=["Wheel", "Hinge"],

    # Set the maximum number of used parts. The
    # actual number will be determined by a
    # random pick and some input / output constraints.
    max_parts=15,
Пример #4
0
    PartSpec(
        body_part=Wheel,
        arity=1,
        outputs=1,

        # Add color parameters to this part
        params=color_params),
    "Hinge":
    PartSpec(body_part=PassiveHinge,
             arity=2,
             params=color_params +
             [ParamSpec("length", min_value=0.1, max_value=1, default=0.5)])
})

# For the brain, we use the default neural network
brain_spec = default_neural_net()

# Specify a body generator for the specification
body_gen = BodyGenerator(
    body_spec,

    # List all parts that can serve as the robot root
    root_parts=["Core"],

    # List all parts that can be attached
    attach_parts=["Wheel", "Hinge"],

    # Set the maximum number of used parts. The
    # actual number will be determined by a
    # random pick and some input / output constraints.
    max_parts=15,