示例#1
0
 def get_manifest(self, data):
     fn = tempfile.mktemp()
     open(fn, "w").write(data)
     try:
         return digest.parse_manifest(self.convert_source(fn))
     finally:
         os.unlink(fn)
示例#2
0
 def get_manifest(self, data):
     fd, fn = tempfile.mkstemp()
     os.write(fd, data.encode())
     os.close(fd)
     try:
         return digest.parse_manifest(self.convert_source(fn))
     finally:
         os.unlink(fn)
示例#3
0
 def get_manifest(self, data):
     fd, fn = tempfile.mkstemp()
     os.write(fd, data.encode())
     os.close(fd)
     try:
         return digest.parse_manifest(self.convert_source(fn))
     finally:
         os.unlink(fn)