示例#1
0
def test_fetch_external_package_is_noop(install_mockery, fetching_not_allowed):
    """do_fetch for packages without code should be a no-op"""
    spec = Spec('a').concretized()
    spec.external_path = "/some/where"
    assert spec.external
    spec.package.do_fetch()
示例#2
0
 def test_no_conflixt_in_external_specs(self, conflict_spec):
     # clear deps because external specs cannot depend on anything
     ext = Spec(conflict_spec).copy(deps=False)
     ext.external_path = '/fake/path'
     ext.concretize()  # failure raises exception