def get_xfamilygroup(self, only_combined=True): """ Get an xbrowse FamilyGroup from the families in this project only_combined means only consider families that have at least one aff and unaff (with variant data) TODO: what is a better name for only_combined?!?!? """ families = [f for f in self.get_families() if f.has_aff_and_unaff()] return XFamilyGroup([family.xfamily() for family in families])
def xfamilygroup(self): return XFamilyGroup( [family.xfamily() for family in self.get_families()])